Mazda MX-5 Miata banner
1 - 6 of 6 Posts

·
Miss me?
Joined
·
4,552 Posts
For some bizarre reason, both the wipers & washer have stopped working - except that now there's a buzzing noise that seems to be coming from the switch behind the stalk & also the heated rear window icon illuminates dimly on the dash.

I had moved the washer bottle prior to this happening but ensured that the earth has been replaced & I've also tried re-earthing in different locations. For all intents & purposes I would say there's a short somewhere but none of the wiring has been touched
 

·
Registered
Joined
·
141 Posts
Im fairly certain it is yeah ( youll hear the buzzing coming from the switch) , I know it sounds kinda daft but going up down forward and back a few times seamed to sort it on mine. im guessing mine is on its way out.
 

·
Miss me?
Joined
·
4,552 Posts
I'm still having no joy with this & it's done nothing but piss it down ever since the problem first arose.....Rain-X will only do so much & is utterly crap when in slow moving traffic/misty drizzle, in fact it just makes matters worse


When I move the wiper stalk down one position to intermittent, it buzzes but no wipers......move the stalk down again & the buzzing stops but now the heated rear window icon illuminates dimly & still no wipers.......washer does not work also.

When I switch on the heated rear window, the buzzing stops & the HRW icon illuminates fully......also, same thing happens when I switch on the AC - ie; the buzzing stops & the HRW icon illuminates fully.

WTF???....anyone?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top