Mazda MX-5 Miata banner
21 - 29 of 29 Posts

Happily expanding the To Do list since 1997
Joined
10,694 Posts
I didn't have kickback exactly but poor starting improved when I made sure my ignition timing wasn't before TDC. With the Mk.1 CAS you only get 1 timing pulse per rev and the cranking engine must presumably be able to speed up and slow down quite a bit during each turn due to compression. So for the ECU to guess where the timing is just before it's due another timing pulse must be really inaccurate.

Anyway I switched to using Mk.2 sensors on my Mk.1 engine combined with a 36-2 trigger wheel. A but of a sledgehammer to crack a nut perhaps but while my car has 99 problems*, starting ain't one.

*Going to The MX-5 Restorer next week. Looking forward to falling back in love with ol' rusty.

PS will dig out my old laptop and have a look similarly.
 

Registered
Joined
307 Posts
Discussion Starter · #22 ·
I used to get this a lot on my '97 1.8 with MS2 but haven't had it for over a year now and I haven't changed any parts related to starting or charging. I used to think it was the battery voltage dropping too low (measured down to 8.7V in the logs) but I'm still getting that kind of voltage on cranking. I checked back to my 2020 MSQs and the only relevant difference I can find is that I dropped the cranking dwell from 6ms to 5ms. Doesn't seem like much, but might be worth a try.

FWIW your cranking fuel pulse is a lot higher than mine. At 20C I'm at 200%.

Reading your comment on warm starts being OK - another long shot here - what grade of oil are you using? 0W40 will be thinner and give easier cold cranking than 15W40 for example.

Good luck tracking it down!
Thanks,, ill give the dwell time a go, worth a try!
I increased the cranking fuel pulse a few weeks ago to try and stop the car dying initially after starting, seemed to work. Think i might of upped the fuel on the after start enrichment too.
I am using 15/40 oil, so could try a thinner oil next time i change it, which wont be long now..
馃憤馃憤
 

Registered
Joined
307 Posts
Discussion Starter · #23 ·
I didn't have kickback exactly but poor starting improved when I made sure my ignition timing wasn't before TDC. With the Mk.1 CAS you only get 1 timing pulse per rev and the cranking engine must presumably be able to speed up and slow down quite a bit during each turn due to compression. So for the ECU to guess where the timing is just before it's due another timing pulse must be really inaccurate.

Anyway I switched to using Mk.2 sensors on my Mk.1 engine combined with a 36-2 trigger wheel. A but of a sledgehammer to crack a nut perhaps but while my car has 99 problems*, starting ain't one.

*Going to The MX-5 Restorer next week. Looking forward to falling back in love with ol' rusty.

PS will dig out my old laptop and have a look similarly.
Thanks.. I have been wondering if the cas could be on its way out, possibly, as the car used to do it occasionally on the stock ecu as explained a few posts above.. Probably overthinking it though, would probably have more severe symptoms at a guess.
 

Registered
Joined
1,130 Posts
Both need charging. In the meantime have a read if this:-
 

Registered
Joined
307 Posts
Discussion Starter · #28 ·
Hope that helps, cranking speed is set to 450rpm.
As suggested in the article I posted, it is more likely to be ignition timing related.
Thanks, ive entered in gitaristinanime's settings earlier, ill see how they go, then try yours. Thanks for going to the effort to post them up on here, very much appriciated 馃憤馃憤
And to everyone else that has reply'd also馃憤馃憤馃憦馃憦

Im hoping it doesnt go as far as needing a different trigger wheel, as im not sure if its as simple as replacing mine, or weather i will need a bunch of other parts too, and a complete remap? (after reading the link you posted..)
 

Registered
Joined
307 Posts
Discussion Starter · #29 ·
Well tried all the various settings above, made no diffrence. Spoke to the guys that tuned the ms3 and they suggested going into negative figures on the cranking timing.
Tried -10 degrees, is a bit harder to start, and it STILL does it. I give up now.
 
21 - 29 of 29 Posts
Top