Mazda MX-5 Miata banner
61 - 80 of 130 Posts

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #63 ·
What is strange is it drove home and no batt light on.. despite only being on 12v... makes me suspect ecu car is needed for cadwell thursday.. so i need to find a alternator asap to test.

Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #64 ·
2 alternators off..yep i climbed over car had a fight with a viscous thorned bush.. ive just retapped threads etc. Having a breather b4 i fit donor and fingers crossed as if i gotta get ecu out gonna be a mission in donor. Lol


Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #66 ·
Quick update on 10ae.
2nd hand rad fitted from suffolk mazda on ebay.. been getting all my bits n bobs lately from them.
Cheap and fast delivery.
There were no fins left on the original rad prob due to bits of rubber hitting it so i spent £28 delivered on another 1. Duly fitted and no more rad cap liftage.
Bit of black grill left over in garage so cable tied in ghetto style stop the rubber bits hitting this 1. Ran a pipe up expansion vessel overflow hole and directed up on windscreen so if boils up squirts on windscreen so you now lol.
Im prob gonna use it at Thruxton in sept so i wanna rollbar..
Looked at trlane and gcf fabs.
Need a harness bar 1. Whats the general consesus of best?

Sent from my SM-N950F using Tapatalk
 

·
Banish a little rust a day people
Joined
·
5,358 Posts
Gfr bars are really good, need to trim more of the interior and they take up a tiny bit of seat space but they give better protection, the GFC versions are also good and trlane style. Caged Lazer are another good one which are somewhere between the 2.

Iv seen too many issues with trlane fitment to want to bother. But the can be had used very cheap
 

·
Banish a little rust a day people
Joined
·
5,358 Posts
IMO if you want track protection and arent taller than 5'10 go GCR otherwise Cagedlaser. Now im on my laptop i'll expand a bit more about the TRLane issues I've seen- my hardtop came from someone selling it as the TRLane bar was so out it fouled a HT, a few friends have had some where the legs were too wide to fit between the rear rails and needed bending with a racket strap to squeeze in and one who had one where the legs where slightly off and wouldnt all sit flush at the same time. Now I'm not slagging them off before someone gets funny, I'm just recounting issues that I've seen that have personally put me off getting a bar from them.

I've not had experience with cagedlaser myself but I hear about them a lot and have seen a lot of their custom cages at shows and am going with their X brace bar for the supercharged NB when I can.
 

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #71 ·
they are literally up the road from me so im prob going with Caged laser i can pick up and save on the postage. Im gonna ring tomoz and see about stock.

Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #75 ·
10ae..faultless at Donington...i didnt drive it but mate said brakes were fantastic.. took out bluestuff on front and replaced bluestuff all round. He said better so i can only assume rears where helping front as some oem delphi 1s.
It did 456 miles in day... drove to donny and back and trackday itself..
I replaced the alternator belt todo as it was shreaking the other day and i overtightened it...shouldve put a new 1 on when alternator changed.


Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #76 ·
So time for 10ae to have an interior valet.
Mates dandruff everywhere and hes got covid so i anti bact it lol.
Cleaned the stains outta seats and autoglymed vinyl n leather cared everywhere.. looking very nice now.


Sent from my SM-N950F using Tapatalk
 

·
Registered
Joined
·
2,879 Posts
Discussion Starter · #78 ·
The 10ae has developed a fault...
On warm up phase about 5 mins into driving it does not like throttle inputs.. like limp mode..need to change gear to wake it back up...after about 2 mins of this when gauge showing fully warm absolutely fine and will continue to be fine all day...
So its fully serviced new leads plugs recently and has cam and crank sensors when i first got it...
Theres no lights on dash etc.
Im thinking the engine coolant sensor is the culprit as temp related.. any thoughts?

Sent from my SM-N950F using Tapatalk
 
61 - 80 of 130 Posts
Top