Mazda MX-5 Miata banner
61 - 70 of 70 Posts

·
@Markbcars
Eunos Turbo
Joined
·
857 Posts
Discussion Starter · #61 ·
Back on the car, gave it a quick turnover and it fired up instantly, so i shut it off and pulled the plugs, noticed plug 1 was clean and wet and looking in to the top of the piston, there appeared to be fuel on top... Anyway, double checked the plug worked, it did, ran FUEL pump but couldn't see leaks or the puddle growing, activated the injector at 1 second pulses but again, couldn't see the mist or anything, tried on another and same, so it must just spray into a spot which cant be seen when looking down.





So that's where I am, guessing the injector on cylinder 1 has an issue.

So I think my next move is to remove them all and send off to Injector Tune for a test and clean up...

Did a compression test again now it has been run as the low readings were bothering me..

218
212
207
211

So that's good, not sure why the previous readings were low but I'll take these.

Oh, and thanks to the leak, I noticed a crack in my downpipe. Never rains and all that....



Should be able to get a quick weld patch while in place so not a huge issue.


Beginning to lose patience with the car now. This is on top of the need to swap the gearbox. ffs
 

·
@Markbcars
Eunos Turbo
Joined
·
857 Posts
Discussion Starter · #65 ·
I'll have a mate grind it back a touch and weld up, slightly annoying but just one of those things!

Injectors now off and will get them in the post tomorrow, I've used injector tune before and the results of his work worked wonders. I'll be interested in seeing the report on these, considering they haven't done too many miles since being cleaned by an unknown party.
 

·
@Markbcars
Eunos Turbo
Joined
·
857 Posts
Discussion Starter · #67 ·
First drive with the turbo was on 153500KM, Feb 2017, the car now has 167XXXKM..

Just one of those things I think, won't be a long job to fix while in place, more unlucky than anything.
 

·
@Markbcars
Eunos Turbo
Joined
·
857 Posts
Discussion Starter · #68 ·
Injectors came back, slightly concerning, no leaks discovered. I am just hoping that one of them was stuck and being removed gave it a knock.. I'm waiting for my FPR to arrive, once that comes, I will get it all back together and cross my fingers that it runs perfectly. If not, it then HAS to be the ECU!!



Results were all good, returned within the week with full set of new seals and filters.
 

·
Hiding from the Ayatollah or making Full Metal Jac
Joined
·
1,653 Posts
Glad you've found the issue!!!

I suggest you replace your fuel filter too.
 

·
@Markbcars
Eunos Turbo
Joined
·
857 Posts
Discussion Starter · #70 ·
Right, been out and got it all back together, new FPR, cleaned injectors back on, original CAS back on, new Retro-leads leads, new fuel lines, ready to go!

This time, I switched injector 1 and 4 around, just in case the problem still persists, switching injectors would help identify if the injector or ECU was at faulty.

Turned over, fired up, running smooth! Gave it some light revs to 3k, noticed fuel on that dodgy gasket which I have purposely not fiddled with as yet.

OK.. Pulled plugs to just check them and inside the cylinders, no sign of excess fuel, piston tops dry and all plugs consistent. Dry tips, some wetness on the white part.. All 4 the same.

Put all back together, fired up, let it run longer, fair bit of smoke from the gasket due to the fuel.

So, I'm now thinking, the car is fixed but I have fuel pooled in the exhaust manifold which sits lower than the turbo/downpipe. Exhaust stinks of fuel, AFR gauge is all over the place. Oil stinks of fuel, obviously..



So I'd like to think the issue was a sticking injector which free'd itself when in the post but has now been cleaned.

Now I need to do an oil change, fit new fuel filter while I'm at it, tighten or replace the gasket and lets see if I do have a pool or not.

Stick to my 10/40 magnatec or switch to Miller CFS..
 
61 - 70 of 70 Posts
Top