Mazda MX-5 Miata banner
1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hey all,

Went to take the mx5 for a spin yesterday...fired up as normal, then almost immediately died.

Car continues to turn over but won't start. I've put the battery on quick charge as I think the cranking I've been doing for the last 20 minutes has flattened it.

I've checked the fuses, all good. I'm going to do the usual and check for a spark and fuel on the spark plugs later, but just wondering if anyone else has had similar start-then-immesiately-stop symptoms?

Cheers all,

Paul
 

·
Registered
Joined
·
1,287 Posts
If you have spark then the coil is more than likely going to be okay.

You could find it is your CAS (Cam Angle Sensor) that has failed which is quite common. I had this on mine in the past and it fixed the issues straight away. If you need a replacement on let me know as I have one.

Like mentioned above check for fuel also.
 

·
Registered
Joined
·
16 Posts
Hi again,

Many thanks for your help so far...

I went and cleaned the spark plugs and it came back to life. Odd.

However now the engine is very tappety and loud - it doesn't go away (I drove once around the block but with that loud chattering I thought it best not to take it fully up to temp), and smells like it's running a bit rich. It wasn't even a little tappety before - always really quiet. Something's not right...although it seemed to be actually driving fine.

Think I may have accidentally solved one problem only to start another...?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
I've filmed it...please ignore the fan belt squealing...
Thoughts? Would an oil change suffice? It's not had one since I bought her in the Summer and has probably done a few thousand miles in that time...
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top