Mazda MX-5 Miata banner
ignition
1-15 of 16 Results
  1. Forced Induction & N/A Power Mods
    Finally got the Supercharged NA back on the road after a 4 year absence due to crashing into a combine harvester...... Anyway apart from some alignment issues that need addressing following the rebuilding of the rear subframe & suspension it's been great to get out and drive the car again...
  2. Forced Induction & N/A Power Mods
    Just starting to tune my MX5 Turbo and was hoping someone might have a successful spark and AFR table they would like to share please. My build is a 93' 1.6 with a garret hybrid turbo, 550cc injectors, electronic boost and a VTPS all run by an MS3. Thanks.....................
  3. Wanted
    Hi Everyone! I am looking for a cheap ignition and fuelling solution for an SC project on an 1.8 NB. From AFPR to standalone ECU anything will be considered. Thanks, Gee
  4. How do I...
    My mk1 mx5 has recently been overheating which has now been sorted, turned out to be my water pump leaking. But when I've just come to round to put new spark plugs and ignition leads in, number 3 wont come out? number 4 was a little struggle but when it came out it appeared to have melted and...
  5. Problems
    Hi, I have come across an awkward problem. My roadster, '95 - shy of 170k km has been acting strange. The plastic key, on the left, goes in the barrel and turns, but no lights turn on the dash. When I use the spare key on the right, the lights turn on and the car starts. I have had the car...
  6. Problems
    Hi Guys Could really do with some pointers on this, car is a 99 mk2 1.8 with no history of starting problems. So far I have checked: Fault codes - non showing. Spark - no spark at all. Fuel - after turning the car over the plugs are wet and exhaust smells of unburnt fuel. Battery - Fully...
  7. Problems
    Hi all, Have just posted this question on mx5occ as well as it is doing my head in a bit, Just been trying to set my ignition timing, have bridged TEN and GND on diagnostics port, connected strobe gun etc and tried to set timing with inductor type connector on plug lead one and can't for the...
  8. Problems
    Hi guys, Got a question for u ! I'm looking for voltage values of the 4 pins from the coils ! ( 1800cc from a '94 roadster ) Non running engine, ignition on ! There must be +12v, ground and 2 other values that i'm looking for... Could someone help me with these ? Many thanks ! Cheers
  9. Problems
    1999 Mk2 1.8, 105k Recently shed its alternator belt which hit a number of items at the front of the engine and the old belt was wound behind both the crank pulley and the power steering pump pulley but the car run for a few days after that was sorted. Broke down on the road and the AA towed...
  10. Problems
    Yo guys, My car is abit sluggish to start sometimes, is this perhaps because I literally get in and turn the key to start the car almost instantaneously? I have a feeling I should wait five seconds or so to let the immobilizer kick in before starting or it will turn over for a few seconds...
  11. Problems
    Battery was flat thanks to a few months of no use. It cranked but not enough oomph to get it going. Jumped it from the second car, got it running happily and left it ticking over for a good fifteen minutes or so. Switched off and disconnected the leads, checked the Roadster to make sure she'd...
  12. Problems
    Morning all, I have a MX5 MK2 2001 1.8S. I have had some intermittent problems with it since summer last year. The car will start up from cold every time with no problems, once it has been driven to operating temperature and then turned off and left for roughly 30 minutes plus it wont start...
  13. Wanted
    Urgently required- Ignition coil pack for a MK1 1.8 Eunos Thanks in advance
  14. Problems
    Hi Guys, So I'm working on getting my dad's old MK1 back on the road - but I've run into a little problem of not having any electricity! The car ran fine when it was on the road, but since it's been stood offroad for a couple of years now it's declined a little. A couple of months ago we...
  15. Problems
    In the last week, my 79k 1.8 Eunos has developed an issue where it's hesitant to start first-time from cold, like the starter motor is weakening, it (and my other 5, which has never failed to start) normally has the typical strong MX5 thrum when started, but this one sort of stutters and coughs...
1-15 of 16 Results
Top