Stinky Cooling Fan.. - Problems - MX5Nutz Forum

Jump to content

These ads only show for users who are not registered or logged in


Photo

Stinky Cooling Fan..


  • Please log in to reply
6 replies to this topic

#1 Turktowner

Turktowner

    One post wonder

  • New Members
  • 5 posts
  • Gender:Male
  • Location:Hampshire

Posted 13 April 2021 - 07:59 AM

Hello, I need some help please.

 

My 2litre NC went in for it's MOT yesterday, it failed on roll bar rubber covers and a tail lamp, so far so good.

However, the tester told me there was a problem with the cooling fan not coming on.  He said it was probably sticking

on something and when given a nudge it'd fire up.  "OK" says I "I can deal with that".

 

Anyway the 17 mile drive home was accompanied by that acrid fishy smell you get from overheated electrics, there was no hint of an odour on the way  to the MOT station and there was no overheating on the gauge all day.  When when I got home I popped the bonnet and the smell was coming from the front end, the cooling fan area.  I reached in and flicked the fan with my fingers and it would turn but not fire up.

 

I'm going to get the expansion bottle out of the way this weeked and take a better look.  I've quickly searched on Google with no success 

on this subject.  Everything seems to be "fan not working" no mention of a whiff.

 

Hoping you good people can give me some guidance. 

 

Much obliged 

Turk 


  • 0

#2 deviator

deviator

    Learning the 5

  • Members
  • PipPipPipPipPipPip
  • 1309 posts
  • Gender:Male
  • Location:Chesterfield

Posted 13 April 2021 - 08:01 AM

It is certainly sounding like the fan. I presume the temp didn't rise too much during the test/driving?
  • 0

#3 Turktowner

Turktowner

    One post wonder

  • New Members
  • 5 posts
  • Gender:Male
  • Location:Hampshire

Posted 13 April 2021 - 08:52 AM

Thanks for the reply @deviator.

That's what strikes me as odd, the needle has never gone beyond a third up. 

 

As a side note, there aren't may 2nd hand fans out there? I've got a Haynes on the way.. :)


  • 0

#4 deviator

deviator

    Learning the 5

  • Members
  • PipPipPipPipPipPip
  • 1309 posts
  • Gender:Male
  • Location:Chesterfield

Posted 13 April 2021 - 10:13 AM

I find that odd. Considering the Mk3 is now in the age of rust and the engines are known to drink oil, I would have thought there would be plenty.
  • 0

#5 deviator

deviator

    Learning the 5

  • Members
  • PipPipPipPipPipPip
  • 1309 posts
  • Gender:Male
  • Location:Chesterfield

Posted 13 April 2021 - 10:19 AM

Secondhand on eBay

  • 0

#6 Turktowner

Turktowner

    One post wonder

  • New Members
  • 5 posts
  • Gender:Male
  • Location:Hampshire

Posted 13 April 2021 - 10:30 AM

 

That's brilliant @deviator, I found loads of 1.6 and 1.8 type fans but not that one.  Ordered!

Many thanks, that's much appreciated.

Cheers.


  • 0

#7 Turktowner

Turktowner

    One post wonder

  • New Members
  • 5 posts
  • Gender:Male
  • Location:Hampshire

Posted 04 May 2021 - 01:54 PM

@deviator

Quick update, the ebay fan has been fitted and all is well.  Mech reckons the motor itself was at fault.

Thanks again, much obliged. :)


  • 0




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users